Sonos app requirements

This article provides the operating system and device requirements for the Sonos S1 controller and Sonos S2 app. See our article on Sonos system setup requirements for information on network, home theater, and music library requirements.



Mobile device OS requirements

An iOS or Android device is required to set up a new Sonos system or add new products. The Sonos app is available for the following OS versions:


Sonos S2 app

  • iOS 14 and higher
  • iPadOS 14 and higher
  • Android 8.0 and higher (Not supported on Chromebooks)
  • Fire OS 7 and higher

Sonos S1 app

  • iOS 12 and higher
  • iPadOS 13 and higher
  • Android 8.0 and higher (Not supported on Chromebooks)
  • Fire OS 7 and higher


Some OS versions are no longer supported, but still work with basic Sonos features like browsing music and controlling playback. For more information, see our article on unsupported OS versions.



Windows and macOS requirements

Sonos supports the following macOS and Windows versions but certain system management features, such as setting up a new Sonos system or adding new products, are not available. See our article on the features of the Sonos desktop app for more details.


Sonos S2 desktop app

  • macOS 10.11 and higher
  • Windows 8 and higher

Sonos S1 desktop app

  • macOS 10.11 and higher
  • Windows 7 and higher


Check your device’s operating system

The following links have more information about updating to a Sonos compatible OS version, if your device supports it. Be advised that upgrading a device’s operating system can adjust settings, features, and change support for other apps. Prior to updating, please check with your device’s manufacturer if you’re not sure what may change after the update.

Still need help?

Our technicians can help over the phone or with a live chat. You can also ask questions and find answers with other Sonos owners in our Sonos Community.